centos8の依存関係に引っ掛かってupdate出来なかった。

色んなパッケージを使ってるとupdate時に依存関係で
すんなりupdate出来ない時がありますが、今回も引っ掛かりました。

3つのパッケージで引っ掛かってるようです。

Error:
Problem 1: cannot install both OpenEXR-libs-2.2.0-12.el8.x86_64 and OpenEXR-libs-2.2.0-11.el8.x86_64
– package OpenEXR-devel-2.2.0-11.el8.x86_64 requires OpenEXR-libs(x86-64) = 2.2.0-11.el8, but none of the providers can be installed
– cannot install the best update candidate for package OpenEXR-libs-2.2.0-11.el8.x86_64
– problem with installed package OpenEXR-devel-2.2.0-11.el8.x86_64
Problem 2: cannot install both ilmbase-2.2.0-13.el8.x86_64 and ilmbase-2.2.0-11.el8.x86_64
– package ilmbase-devel-2.2.0-11.el8.x86_64 requires ilmbase(x86-64) = 2.2.0-11.el8, but none of the providers can be installed
– cannot install the best update candidate for package ilmbase-2.2.0-11.el8.x86_64
– problem with installed package ilmbase-devel-2.2.0-11.el8.x86_64
Problem 3: cannot install both libgs-9.27-1.el8.x86_64 and libgs-9.25-7.el8.x86_64
– package libgs-devel-9.25-7.el8.x86_64 requires libgs(x86-64) = 9.25-7.el8, but none of the providers can be installed
– cannot install the best update candidate for package libgs-9.25-7.el8.x86_64
– problem with installed package libgs-devel-9.25-7.el8.x86_64
(try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

–skip-broken等はつかいたくなかったので
CentOS-Linux-PowerTools.repo
を有効にしてupdateを再実行したら依存関係に引っ掛からずにupdateに成功しました。

ブックマーク パーマリンク.

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です