PHPのインストールでError: Packageが出た時のメモ


Centos7でPHP7の環境を作ろうと↓の感じでyum install を行った際に

yum install php70 php-fpm nginx php70-php-mcrypt php70-php-mbstring php70-php-fpm php70-php-gd php-pecl-memcached memcached memcached-devel

大量にError: Packageと出力された。

Error: Package: php-pecl-memcached-3.0.0-0.1.20160217git6ace07d.el7.remi.7.0.x86_64 (remi-php70)
Requires: php(api) = 20151012-64
Installing: php-common-5.4.16-36.el7_1.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-igbinary-1.2.2-0.1.20151217git2b7c703.el7.remi.7.0.x86_64 (remi-php70)
Requires: php(zend-abi) = 20151012-64
Installing: php-common-5.4.16-36.el7_1.x86_64 (base)
php(zend-abi) = 20100525-64
Error: Package: php-pecl-msgpack-2.0.1-1.el7.remi.7.0.x86_64 (remi-php70)
Requires: php(zend-abi) = 20151012-64
Installing: php-common-5.4.16-36.el7_1.x86_64 (base)
php(zend-abi) = 20100525-64
Error: Package: php-pecl-igbinary-1.2.2-0.1.20151217git2b7c703.el7.remi.7.0.x86_64 (remi-php70)
Requires: php(api) = 20151012-64
Installing: php-common-5.4.16-36.el7_1.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-msgpack-2.0.1-1.el7.remi.7.0.x86_64 (remi-php70)
Requires: php(api) = 20151012-64
Installing: php-common-5.4.16-36.el7_1.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-memcached-3.0.0-0.1.20160217git6ace07d.el7.remi.7.0.x86_64 (remi-php70)
Requires: php(zend-abi) = 20151012-64
Installing: php-common-5.4.16-36.el7_1.x86_64 (base)
php(zend-abi) = 20100525-64
You could try using --skip-broken to work around the problem

remiを見に行かずbaseリポジトリを見に行っているようなので

remi-php70.repo

priority=1

を書いた所、すんなりインストールできました

PHPのインストールでError: Packageが出た時のメモ” への1件のフィードバック

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です